<!DOCTYPE html><html lang="en"><head><link rel="manifest" href="/manifest.json"/><meta name="theme-color" content="#001636"/><link rel="apple-touch-icon" href="/images/icons/news18_57x57_v1.png"/><link rel="apple-touch-icon" sizes="57x57" href="/images/icons/news18_57x57_v1.png"/><link rel="apple-touch-icon" sizes="72x72" href="/images/icons/news18_72x72_v1.png"/><link rel="apple-touch-icon" sizes="76x76" href="/images/icons/news18_76x76_v1.png"/><link rel="apple-touch-icon" sizes="114x114" href="/images/icons/news18_114x114_v1.png"/><link rel="apple-touch-icon" sizes="120x120" href="/images/icons/news18_120x120_v1.png"/><link rel="apple-touch-icon" sizes="144x144" href="/images/icons/news18_144x144_v1.png"/><link rel="apple-touch-icon" sizes="152x152" href="/images/icons/news18_152x152_v1.png"/><link rel="apple-touch-icon" sizes="167x167" href="/images/icons/news18_167x167_v1.png"/><link rel="apple-touch-icon" sizes="180x180" href="/images/icons/news18_180x180_v1.png"/><link rel="apple-touch-icon" sizes="192x192" href="/images/icons/news18_192x192_v1.png"/><link rel="apple-touch-icon" sizes="512x512" href="/images/icons/news18_512x512_v1.png"/><meta charSet="utf-8"/><title class="jsx-4037962195">&#x27;The Buck Stops With The Coach and The Captain, Only Selectors Can&#x27;t Be Blamed&#x27;: K Shriniwas Rao</title><meta name="title" content="&#x27;The Buck Stops With The Coach and The Captain, Only Selectors Can&#x27;t Be Blamed&#x27;: K Shriniwas Rao" class="jsx-4037962195"/><meta name="description" content="The Board of Control for Cricket in India (BCCI) has sacked the Chetan Sharma-led selection committee after India’s debacle in the T20 World Cup 2022. The cricket board has also invited applications for the position of National Selectors on Friday." class="jsx-4037962195"/><meta name="keywords" content="K Shriniwas Rao, Ayaz Memon, Rohit Sharma, Rahul Dravid, Indian Selectors, Chetan Sharma, BCCI" class="jsx-4037962195"/><meta name="news_keywords" content="K Shriniwas Rao, Ayaz Memon, Rohit Sharma, Rahul Dravid, Indian Selectors, Chetan Sharma, BCCI" class="jsx-4037962195"/><meta name="viewport" content="width=device-width, initial-scale=1.0" class="jsx-4037962195"/><meta name="twitter:title" content="&#x27;The Buck Stops With The Coach and The Captain, Only Selectors Can&#x27;t Be Blamed&#x27;: K Shriniwas Rao" class="jsx-4037962195"/><meta name="twitter:description" content="The Board of Control for Cricket in India (BCCI) has sacked the Chetan Sharma-led selection committee after India’s debacle in the T20 World Cup 2022. The cricket board has also invited applications for the position of National Selectors on Friday." class="jsx-4037962195"/><meta name="twitter:url" content="https://www.news18.com/cricketnext/news/the-buck-stops-with-the-coach-and-the-captain-only-selectors-cant-be-blamed-k-shriniwas-rao-6482887.html" class="jsx-4037962195"/><meta name="twitter:creator" content="@cnnnews18" class="jsx-4037962195"/><meta name="twitter:site" content="CNNNews18" class="jsx-4037962195"/><meta name="twitter:card" content="summary_large_image" class="jsx-4037962195"/><meta name="twitter:widgets:csp" content="on" class="jsx-4037962195"/><meta property="twitter:account_id" content="4503599627804328" class="jsx-4037962195"/><meta property="fb:pages" content="31867849201" class="jsx-4037962195"/><meta property="fb:app_id" content="115930713951815" class="jsx-4037962195"/><script type="application/ld+json">{"@context":"https://schema.org","@type":"ImageObject","author":"Cricketnext Staff","contentUrl":"https://images.news18.com/ibnlive/uploads/2022/07/rohit-sharma-rahul-dravid-bcci-16591737753x2.jpg?impolicy=website&width=1200&height=800","datePublished":"2022-11-27T18:24:34+05:30","description":"Ayaz Memon said that he doesn't agree with only the selection panel being sacked","name":"'The Buck Stops With The Coach and The Captain, Only Selectors Can't Be Blamed': K Shriniwas Rao"}</script><link rel="icon" href="https://images.news18.com/static_news18/pix/ibnhome/news18/favicon.ico" class="jsx-4037962195"/><meta property="og:title" content="&#x27;The Buck Stops With The Coach and The Captain, Only Selectors Can&#x27;t Be Blamed&#x27;: K Shriniwas Rao" class="jsx-4037962195"/><meta property="og:description" content="The Board of Control for Cricket in India (BCCI) has sacked the Chetan Sharma-led selection committee after India’s debacle in the T20 World Cup 2022. The cricket board has also invited applications for the position of National Selectors on Friday." class="jsx-4037962195"/><meta name="twitter:image" content="https://images.news18.com/ibnlive/uploads/2022/07/rohit-sharma-rahul-dravid-bcci-165917377516x9.jpg" class="jsx-4037962195"/><meta name="twitter:image:alt" content="Team India captain Rohit Sharma and head coach Rahul Dravid" class="jsx-4037962195"/><meta property="og:image" content="https://images.news18.com/ibnlive/uploads/2022/07/rohit-sharma-rahul-dravid-bcci-165917377516x9.jpg" class="jsx-4037962195"/><meta property="og:image:width" content="1600" class="jsx-4037962195"/><meta property="og:image:height" content="900" class="jsx-4037962195"/><meta property="og:image:alt" content="Team India captain Rohit Sharma and head coach Rahul Dravid" class="jsx-4037962195"/><meta itemprop="image" content="https://images.news18.com/ibnlive/uploads/2022/07/rohit-sharma-rahul-dravid-bcci-165917377516x9.jpg" class="jsx-4037962195"/><link rel="preconnect" href="https://images.news18.com" class="jsx-4037962195"/><link rel="dns-prefetch" href="https://www.google.com" class="jsx-4037962195"/><link rel="dns-prefetch" href="https://ads.pubmatic.com" class="jsx-4037962195"/><link rel="dns-prefetch" href="https://securepubads.g.doubleclick.net" class="jsx-4037962195"/><link rel="preload" as="font" type="font/woff2" crossorigin="anonymous" href="https://images.news18.com/static_news18/pix/ibnhome/news18/fonts/fira-sans-v15-latin-regular.woff2" class="jsx-4037962195"/><link rel="preload" as="font" type="font/woff2" crossorigin="anonymous" href="https://images.news18.com/static_news18/pix/ibnhome/news18/fonts/fira-sans-v15-latin-700.woff2" class="jsx-4037962195"/><script type="text/javascript">function adRecoverScript() {
        (function (w, d) { var s = d.createElement("script"); s.src = "//delivery.adrecover.com/43988/adRecover.js"; s.type = "text/javascript"; s.async = true; (d.getElementsByTagName("head")[0] || d.getElementsByTagName("body")[0]).appendChild(s); })(window, document);
    }
        var PWT = {};
        function nw18PWTScript() {
            (function () {
                var purl = window.location.href;
                var url = '//ads.pubmatic.com/AdServer/js/pwt/113941/2778';
                var profileVersionId = '';
                if (purl.indexOf('pwtv=') > 0) {
                    var regexp = /pwtv=(.*?)(&|$)/g;
                    var matches = regexp.exec(purl);
                    if (matches.length >= 2 && matches[1].length > 0) {
                        profileVersionId = '/' + matches[1];
                    }
                }
                var wtads = document.createElement('script');
                wtads.async = true;
                wtads.type = 'text/javascript';
                wtads.src = url + profileVersionId + '/pwt.js';
                var node = document.getElementsByTagName('script')[0];
                node.parentNode.insertBefore(wtads, node);
            })();
        }
        function nw18APSScript() {
            let aps = document.createElement('script');
            aps.async = true;
            aps.type = 'text/javascript';
            aps.src = "https://c.amazon-adsystem.com/aax2/apstag.js";
            var node = document.getElementsByTagName('script')[0];
            node.parentNode.insertBefore(aps, node);

        }
        setTimeout(() => {
            nw18PWTScript();
            nw18APSScript();
            PWT.jsLoaded = function () {
                window.DFPManager.load();
            }
        }, 2000);
        setTimeout(() => {
            adRecoverScript();
        }, 3000);
       </script><link rel="canonical" href="https://www.news18.com/cricketnext/news/the-buck-stops-with-the-coach-and-the-captain-only-selectors-cant-be-blamed-k-shriniwas-rao-6482887.html" class="jsx-4037962195"/><link rel="amphtml" href="https://www.news18.com/cricketnext/amp/news/the-buck-stops-with-the-coach-and-the-captain-only-selectors-cant-be-blamed-k-shriniwas-rao-6482887.html" class="jsx-4037962195"/><script type="text/javascript">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</script><meta name="robots" content="max-image-preview:large"/><meta name="next-head-count" content="39"/><link rel="preload" href="/_next/static/css/17597d3694d41727ad30.css" as="style"/><link rel="stylesheet" href="/_next/static/css/17597d3694d41727ad30.css"/><noscript data-n-css=""></noscript><script defer="" nomodule="" src="/_next/static/chunks/polyfills-a40ef1678bae11e696dba45124eadd70.js"></script><script defer="" src="/_next/static/chunks/1122-cef76625658fb227e8b9.js"></script><script defer="" src="/_next/static/chunks/30653-88615f3067763c8fc651.js"></script><script defer="" src="/_next/static/chunks/31516-79573af59dd87a6a58bb.js"></script><script defer="" src="/_next/static/chunks/1216-6f9babf4ba01a9544c30.js"></script><script defer="" src="/_next/static/chunks/86961-8ec720fbff7f00741739.js"></script><script defer="" src="/_next/static/chunks/38039-87b6148c2925a9fa21d1.js"></script><script defer="" src="/_next/static/chunks/23228-e32edeb1cf69824fe460.js"></script><script defer="" src="/_next/static/chunks/65046-2d5ea370edcf08ab7643.js"></script><script defer="" src="/_next/static/chunks/74258-7ff7ec65065fffb4051d.js"></script><script defer="" src="/_next/static/chunks/25675-734edd77b864c56647e6.js"></script><script defer="" src="/_next/static/chunks/25935-0ff3a0b57d01e57ebfed.js"></script><script defer="" src="/_next/static/chunks/54116-c157752b33ee9f624a6a.js"></script><script defer="" src="/_next/static/chunks/46066-3bb592eb09b80cb9ef43.js"></script><script defer="" src="/_next/static/chunks/80921.93f2418b97fd59466312.js"></script><script defer="" src="/_next/static/chunks/89037-0604b843cb8e3e277371.js"></script><script defer="" src="/_next/static/chunks/19110-f9e9167ab09a288bb9bf.js"></script><script defer="" src="/_next/static/chunks/47490-9a85434abab4dc67a3c7.js"></script><script defer="" src="/_next/static/chunks/61248.02775874f3c285378bd8.js"></script><script defer="" src="/_next/static/chunks/25144.8b9df156384a775052e4.js"></script><script defer="" src="/_next/static/chunks/34067.bd34c7a20a4250e8d8fe.js"></script><script defer="" src="/_next/static/chunks/23994.072b94072b5bf70fe5a6.js"></script><script src="/_next/static/chunks/webpack-bfcb5b236e1bb908a568.js" defer=""></script><script src="/_next/static/chunks/framework-a43af322d6c0069d5762.js" defer=""></script><script src="/_next/static/chunks/main-90b40da65b94e6f64e20.js" defer=""></script><script src="/_next/static/chunks/pages/_app-7db0598d7da7dbd7732e.js" defer=""></script><script src="/_next/static/chunks/75fc9c18-a04362b878fbbdc0f639.js" defer=""></script><script src="/_next/static/chunks/20259-c3d8bebac5b8ceff8f3d.js" defer=""></script><script src="/_next/static/chunks/93820-cc0c696b233828e63252.js" defer=""></script><script src="/_next/static/chunks/52759-de6a8af090e66d10b171.js" defer=""></script><script src="/_next/static/chunks/35138-d7850b386fbf35043b78.js" defer=""></script><script src="/_next/static/chunks/92906-afc69b3f207e50ef8002.js" defer=""></script><script src="/_next/static/chunks/pages/article-8f4219241b42739e0ea8.js" defer=""></script><script src="/_next/static/k68zut5vhzsk6ufTceI4Q/_buildManifest.js" defer=""></script><script src="/_next/static/k68zut5vhzsk6ufTceI4Q/_ssgManifest.js" defer=""></script><style id="__jsx-435456715">.gsc-modal-background-image{height:382px !important;}.gsc-results-wrapper-overlay{height:378px !important;}.gsearch_box{width:auto;}.spriteimage1{background:url(https://images.news18.com/static_news18/pix/ibnhome/news18/top-nav/sprite-image.png) no-repeat;display:inline-block;}.search_icon{width:20px;height:20px;vertical-align:middle;margin-top:4px;cursor:pointer;background-image:url(https://images.news18.com/static_news18/pix/ibnhome/news18/search-icon.svg);}.exp_search{background:#d6d6d6;padding:10px;position:absolute;top:45px;right:0;z-index:999999999;width:600px;display:none;}.expinner{background:#fff;border:1px solid #dedede;position:relative;height:auto;}.header_search{position:absolute;right:10px;top:10px;z-index:9999;padding-left:9px;}.Open{-webkit-transform:translateX(0);-ms-transform:translateX(0);transform:translateX(0);display:block;}.Close{-webkit-transform:translateX(-100%);-ms-transform:translateX(-100%);transform:translateX(-100%);display:none;}</style><style id="__jsx-10193515">div#advertisement{display:inline-block;width:100%;font-size:12px;color:#797e90;padding:1px 0px;background:#e6e6e6;text-align:center;line-height:14px;font-family:'Fira Sans';}</style><style id="__jsx-4035473718">#credential_picker_container{top:45px !important;}</style><style id="__jsx-827212424">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</style><style id="__jsx-2953342531">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</style><style id="__jsx-1609252102">.tely{background:#0088CC !important;}.articleshare-new{width:40px;position:relative;margin-left:-60px;top:50px;margin-bottom:200px;}.articleshare-new-in{position:-webkit-sticky;position:sticky;top:60px;}.articleshare-new-in a{width:40px;height:40px;display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-box-pack:center;-webkit-justify-content:center;-ms-flex-pack:center;justify-content:center;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;background:red;margin-bottom:1px;}.articleshare-new-in a svg{-webkit-filter:brightness(0) invert(1);filter:brightness(0) invert(1);height:22px;}.articleshare-new-in a:nth-child(2) svg{height:20px;}.articleshare-new-in a:nth-child(4) svg{height:18px;}.articleshare-new-in a:nth-child(5) svg{height:14px;}.articleshare-new-in a:nth-child(1){background:#25d366;}.articleshare-new-in a:nth-child(2){background:#1877f2;}.articleshare-new-in a:nth-child(3){background:#1da1f2;}.articleshare-new-in a:nth-child(4){background:#ef3f56;}.articleshare-new-in a:nth-child(5){background:#4e4e4e;}</style><style id="__jsx-1429733795">.insidefollwicon{display:inline-block;margin-left:-6px;height:44px;}.insidefollwicon a{font-size:12px;text-transform:none;color:#949494;-webkit-text-decoration:underline;text-decoration:underline;margin-right:11px;margin-bottom:11px;display:inline-block;}.insidefollwicon a:first-child svg{width:14px;height:12px;}.insidefollwicon a svg{width:16px;height:16px;display:inline-block;vertical-align:middle;margin-right:4px;opacity:.7;}.cls-1{fill:#494949;}.cls-2{fill:#004d40;}.cls-10,.cls-2,.cls-3,.cls-5,.cls-9{opacity:0.2;}.cls-2,.cls-3,.cls-5,.cls-9{isolation:isolate;}.cls-3,.cls-8{fill:#fff;}.cls-4{fill:#ea4335;}.cls-5{fill:#3e2723;}.cls-6{fill:#ffc107;}.cls-7{fill:#4285f4;}.cls-11,.cls-9{fill:#1a237e;}.cls-12{fill:url(#radial-gradient);}</style><style id="__jsx-806591267">.error.jsx-806591267{border:2px solid #ed2128;}.sectionRight.jsx-806591267{width:300px;}</style><style id="__jsx-1691880260">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</style><style id="__jsx-341059887">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</style><style id="__jsx-1812159023">.slick-slider{margin-left:-10px;margin-right:-10px;}.slick-prev,.slick-next{width:25px;height:33px;background:#ff0000;cursor:pointer;z-index:9;top:70px;}.slick-prev:hover,.slick-next:hover,.slick-prev:focus,.slick-next:focus{background:#ff0000;}.slick-prev:before,.slick-next:before{content:"";border-top:2px solid #fff;border-left:2px solid #fff;width:12px;height:12px;position:absolute;top:10px;}.slick-prev:before{-webkit-transform:rotate(-45deg);-ms-transform:rotate(-45deg);transform:rotate(-45deg);left:10px;}.slick-next:before{-webkit-transform:rotate(140deg);-ms-transform:rotate(140deg);transform:rotate(140deg);right:10px;}.slick-prev.slick-disabled:before,.slick-next.slick-disabled:before{opacity:1;}.slick-prev{left:10px;}.slick-next{right:10px;}#dy_bottom .slick-prev{top:48px;left:-30px;}#dy_bottom .slick-next{top:48px;right:-30px;}#dy_bottom .slick-prev,#dy_bottom .slick-next{background:transparent;}#dy_bottom .slick-prev:before,#dy_bottom .slick-next:before{display:none;}#dy_bottom .slick-disabled{cursor:default;opacity:0.5;}</style><style id="__jsx-1649376047">.dy_bottom.jsx-303533257{height:111px;padding:10px 51px;background:#F8F8F8 0% 0% no-repeat padding-box;box-shadow:0px -1px 6px #00000029;position:fixed;bottom:0;left:0;right:0;z-index:9999;}#dy_bottom.close.jsx-303533257{display:none;}.dy_bottom.jsx-303533257 .track.jsx-303533257{overflow:hidden;}.dy_bottom.jsx-303533257 .slides.jsx-303533257{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;padding:0;margin:0;}.dy_bottom.jsx-303533257 button.jsx-303533257{background:transparent;border:none;cursor:pointer;}.dy_bottom.jsx-303533257 .close.jsx-303533257{position:absolute;right:17px;top:10px;cursor:pointer;}.dy_bottom.jsx-303533257 .slide.jsx-303533257{background:white;border:1px solid #DDDDDD;padding:8px 10px;display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;height:92px;margin:0 3px;}.dy_bottom.jsx-303533257 .gl_left.jsx-303533257{position:absolute;top:49px;left:19px;}.dy_bottom.jsx-303533257 .gl_right.jsx-303533257{position:absolute;top:49px;right:19px;}.dy_bottom_img.jsx-303533257{position:relative;margin-right:14px;width:110px;-webkit-flex-shrink:0;-ms-flex-negative:0;flex-shrink:0;}.dy_bottom_img.jsx-303533257 .icon_Wrp.jsx-303533257{position:absolute;bottom:2px;right:2px;width:23px;height:20px;display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;-webkit-box-pack:center;-webkit-justify-content:center;-ms-flex-pack:center;justify-content:center;}.dy_bottom_img.jsx-303533257 .icon_Wrp.jsx-303533257{padding-top:4px;}.dy_bottom.jsx-303533257 .live_status.jsx-303533257{width:48px;height:20px;background:#ED1C24;box-shadow:0px 3px 6px #00000029;border-radius:2px;position:absolute;bottom:2px;right:2px;display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;-webkit-align-items:center;-webkit-box-align:center;-ms-flex-align:center;align-items:center;-webkit-box-pack:center;-webkit-justify-content:center;-ms-flex-pack:center;justify-content:center;padding-left:3px;}.dy_bottom.jsx-303533257 .live_status.jsx-303533257 .dot.jsx-303533257{width:6px;height:6px;background:#FFFFFF;position:relative;border-radius:100%;margin-right:8px;}.dy_bottom.jsx-303533257 .live_status.jsx-303533257 .dot.jsx-303533257:before{content:'';width:12px;height:12px;background:#FFFFFF;opacity:0.3;display:block;border-radius:100%;position:absolute;top:-3px;left:-3px;}.dot.jsx-303533257{-webkit-animation:1s blink ease infinite;-moz-animation:1s blink ease infinite;-ms-animation:1s blink ease infinite;-o-animation:1s blink ease infinite;-webkit-animation:1s blink-jsx-303533257 ease infinite;animation:1s blink-jsx-303533257 ease infinite;}.dy_bottom.jsx-303533257 .slide.jsx-303533257 .slide_a.jsx-303533257{display:-webkit-box;display:-webkit-flex;display:-ms-flexbox;display:flex;}@-webkit-keyframes 'blink'-jsx-303533257{from,to{opacity:0;}50%{opacity:1;}}@keyframes 'blink'-jsx-303533257{from,to{opacity:0;}50%{opacity:1;}}@-moz-keyframes blink{from.jsx-303533257,to.jsx-303533257{opacity:0;}50%.jsx-303533257{opacity:1;}}@-webkit-keyframes "blink"{from.jsx-303533257,to.jsx-303533257{opacity:0;}50%.jsx-303533257{opacity:1;}}@-ms-keyframes "blink"{from.jsx-303533257,to.jsx-303533257{opacity:0;}50%.jsx-303533257{opacity:1;}}@-o-keyframes "blink"{from.jsx-303533257,to.jsx-303533257{opacity:0;}50%.jsx-303533257{opacity:1;}}.dy_bottom.jsx-303533257 .live_status.jsx-303533257 span.jsx-303533257{display:inline-block;font-weight:bold;font-size:11px;line-height:18px;color:#FFFFFF;text-transform:uppercase;}.dy_bottom_heading.jsx-303533257{font-weight:bold;font-size:12px;line-height:14px;text-transform:uppercase;padding-left:5px;border-left:#000 solid 5px;border-bottom:#000 solid 1px;display:inline-block;margin-bottom:2px;}.dy_bottom_subhead.jsx-303533257{font-weight:bold;font-size:14px;line-height:20px;color:#222222;margin-top:1px;}.trending.jsx-303533257{color:#E00000;border-color:#E00000;}.editors-pick.jsx-303533257{color:#0092E0;border-color:#0092E0;}.most-read.jsx-303533257{color:#E07000;border-color:#E07000;}.recommended.jsx-303533257{color:#061D40;border-color:#061D40;}</style><style id="__jsx-4037962195">@font-face{font-family:"Fira Sans";src:url("https://images.news18.com/static_news18/pix/ibnhome/news18/fonts/fira-sans-v15-latin-regular.woff2") format("woff2");font-weight:normal;font-style:normal;font-display:optional;}@font-face{font-family:"Fira Sans";src:url("https://images.news18.com/static_news18/pix/ibnhome/news18/fonts/fira-sans-v15-latin-500.woff2") format("truetype");font-weight:500;font-style:normal;font-display:optional;}@font-face{font-family:"Fira Sans";font-style:normal;font-weight:600;src:url(https://images.news18.com/static_news18/pix/ibnhome/news18/fonts/fira-sans-v15-latin-700.woff2) format("woff2");font-display:optional;}@font-face{font-family:'PT Serif';font-style:normal;font-weight:400;src:url('https://images.news18.com/static_news18/pix/ibnhome/news18/fonts/pt-serif-v16-latin-regular.woff2')  format('woff2');font-display:optional;}body{font-family:"Fira Sans",sans-serif;font-size:15px;line-height:1.1;margin:0;padding:0;}.article-content-box::-moz-selection{color:#ffffff;background:#0a2040;}.article-content-box::selection{color:#ffffff;background:#0a2040;}.scoreBlog-content .inner p{font-family:'PT Serif',serif;font-size:16px;line-height:24px;margin-bottom:15px;color:#202020;}.scoreBlog-content .inner p strong{font-weight:bold;}.obBody{padding-bottom:25px;width:728px;height:90px;margin:0 auto;overflow:hidden;}</style><style id="__jsx-2785936298">article,aside,div,figure,form,h1,h2,h3,h4,h5,h6,li,p,section,ul{margin:0;padding:0;box-sizing:border-box;}a,a:hover{-webkit-text-decoration:none;text-decoration:none;}a{color:#282828;}img{border:0;}ul{list-style:none;}article,aside,figure,section{display:block;}.n18thder{text-align:center;min-height:70px;}</style></head><body><div id="__next"><header style="text-align:center" class="jsx-896135805 mainHeader"><div style="background:url(&#x27;data:image/webp;base64,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&#x27;) no-repeat top center;border-top:2px solid #e1261d" class="jsx-896135805 headerInner undefined"><div style="width:1244px;position:relative;margin:0 auto;display:flex;justify-content:space-between" class="jsx-896135805 headerContainer"><div style="display:flex;align-self:center;height:58px;max-width:280px" class="jsx-896135805 topLogoWrap"><a href="https://www.news18.com/" class="jsx-896135805 logo"><img src="data:image/svg+xml;base64,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" alt="News18 Logo" style="width:130px;min-height:47px;max-height:48px" class="jsx-896135805"/></a><h2 style="font-size:38px;color:#fff;font-weight:600;font-family:Fira Sans;text-transform:uppercase;padding-top:11px;margin-left:0px;padding-left:10px;position:relative" class="jsx-896135805 topHeading_cricket"><img src="https://images.news18.com/static_news18/pix/ibnhome/news18/CricketNext.svg" class="jsx-896135805 cricketnext-logo"/></h2></div><div class="jsx-896135805 topRighSection"><div style="display:flex;justify-content:space-between" class="jsx-896135805 topLinksWrap"><div style="background:#e1261d;display:flex;justify-content:space-between;color:#fff;align-items:center;padding-right:0;padding-bottom:0;padding-top:1px;height:26px" class="jsx-896135805 languagebox"><span class="jsx-896135805">CHANGE LANGUAGE</span><div style="background:#fff;padding-left:10px;min-width:130px;color:#6c6c6c;font-size:12px;position:relative;border-radius:0 0 7px 7px;display:flex;align-items:center;height:100%" class="jsx-896135805 linner"><a href="https://www.news18.com/" class="jsx-896135805">English<!-- --> <span class="jsx-896135805 nhlanguate-arrow hsocial-sprite"></span></a><div class="jsx-896135805 lddnav"><a href="https://hindi.news18.com/" target="_blank" rel="noreferrer" class="jsx-896135805">हिन्दी<!-- --> </a><a href="https://bengali.news18.com/" target="_blank" rel="noreferrer" class="jsx-896135805">বাংলা<!-- --> </a><a href="https://lokmat.news18.com/" target="_blank" rel="noreferrer" class="jsx-896135805">मराठी<!-- --> </a><a href="https://gujarati.news18.com/" target="_blank" rel="noreferrer" class="jsx-896135805">ગુજરાતી<!-- --> </a><a href="https://kannada.news18.com/" target="_blank" rel="noreferrer" class="jsx-896135805">ಕನ್ನಡ<!-- --> </a><a href="https://tamil.news18.com/" target="_blank" rel="noreferrer" class="jsx-896135805">தமிழ்<!-- --> </a><a href="https://malayalam.news18.com/" target="_blank" rel="noreferrer" class="jsx-896135805">മലയാളം<!-- --> </a><a href="https://telugu.news18.com/" target="_blank" rel="noreferrer" class="jsx-896135805">తెలుగు<!-- --> </a><a href="https://punjab.news18.com/" target="_blank" rel="noreferrer" class="jsx-896135805">ਪੰਜਾਬੀ<!-- --> </a><a href="https://urdu.news18.com/" target="_blank" rel="noreferrer" class="jsx-896135805">اردو<!-- --> </a><a href="https://assam.news18.com/" target="_blank" rel="noreferrer" class="jsx-896135805">অসমীয়া<!-- --> </a><a href="https://odia.news18.com/" target="_blank" rel="noreferrer" class="jsx-896135805">ଓଡ଼ିଆ<!-- --> </a></div></div></div><div class="jsx-896135805 nhsocial"><strong class="jsx-896135805">Follow Us On</strong><a href="https://www.facebook.com/cnnnews18/" class="jsx-896135805 nhfb-icon hsocial-sprite"></a><a href="https://twitter.com/CNNnews18" class="jsx-896135805 nhtw-icon hsocial-sprite"></a><a href="https://www.instagram.com/cnnnews18/" class="jsx-896135805 nhig-icon hsocial-sprite"></a><a href="https://www.youtube.com/cnnnews18" class="jsx-896135805 nhutb-icon hsocial-sprite"></a><a href="https://t.me/news18dotcom" class="jsx-896135805 ntme-icon hsocial-sprite"></a></div></div><div class="jsx-896135805 headerPartnerWrapper"><div class="jsx-896135805 partnerBox"><div class="jsx-896135805 iplAssociateAd"><div class="jsx-896135805"><div class="nw18-dfp-ad  " data-adcode="/1039154/CRINXT_ENG_DESKTOP/CRINXT_ENG_IPLT20/CRINXT_ENG_IPLT20_AL/CRINXT_ENG_IPLT20_AL_ROS_LOGO1_140x45" data-adsizes="[[140,45]]" style="min-height:px"></div><style>
        .nw18-dfp-ad{display:table;margin:0 auto;}
        .nativeAd{display: block !important;}
      </style></div></div></div></div></div></div></div></header><nav id="stickyNavContainer" style="border-bottom:1px solid #d4d4d4" class="jsx-896135805 "><div style="margin:0 auto;padding:0;width:1244px;display:flex;align-items:center;position:relative" class="jsx-896135805 topNavContainer"><div style="background:transparent;padding-top:12px;border-bottom:1px #222 solid;cursor:pointer" class="jsx-896135805 hamburger"></div><a href="#" class="jsx-896135805 stickyLogo hide"><img src="data:image/svg+xml;base64,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" alt="News18 Logo" style="width:105px" class="jsx-896135805"/></a><ul style="margin-right:auto;margin-left:40px" class="jsx-896135805 CNtopNavList"><li class="jsx-896135805 "><a href="/cricketnext/" class="jsx-896135805"><span class="jsx-896135805 icon"><svg xmlns="http://www.w3.org/2000/svg" width="13.426" height="17" viewBox="0 0 13.426 17"><defs><style>.a{fill:#e1261c;}</style></defs><path class="a" d="M9.116,11.443c-.409.621-.3,1.451-.87,2.015a2.085,2.085,0,0,1,.336.2,1.64,1.64,0,0,1,.3.357c.023.037-.037.175-.089.2a5.22,5.22,0,0,0-.919.5,1.773,1.773,0,0,1-1.243.429A.694.694,0,0,0,6.3,15.2c-.483.182-.969.359-1.441.567-.335.146-.649.339-.991.522a.41.41,0,0,0,.27.477c.1.04.151.195.225.3a1.053,1.053,0,0,1-.316.168,2.12,2.12,0,0,1-.59,0,.654.654,0,0,1-.522-.4c-.134-.287-.305-.556-.461-.833-.063-.11-.139-.214-.191-.329a.311.311,0,0,1,.17-.455,3.647,3.647,0,0,0,.893-.507c.112-.079.226-.174.336.012.012.02.087,0,.162,0l-.132-.278c.21-.03.386-.27.588,0,.2-.134.39-.262.579-.392.038-.026.1-.063.1-.094,0-.328.284-.32.477-.39a3.149,3.149,0,0,1,.548-.108l.176-.334.189.154.366-.519a1.458,1.458,0,0,1,.08-1.08,1.537,1.537,0,0,0-.014-1.3,2.264,2.264,0,0,1-.078-.885c0-.079.1-.172.178-.235.3-.248.3-.322.036-.6a.38.38,0,0,1-.1-.288c.06-.244.161-.478.254-.738-.049-.068-.114-.158-.18-.246A.575.575,0,0,1,6.8,6.873a1,1,0,0,0-.041-.358c-.016-.107-.086-.243-.044-.316.223-.392.108-.829.193-1.236a4.893,4.893,0,0,1,.247-.833.63.63,0,0,1,.3-.26c.173-.088.3-.178.3-.4,0-.062.088-.126.172-.237-.039-.186-.1-.438-.141-.693-.008-.047.033-.147.062-.151.174-.027.183-.165.194-.283a1.1,1.1,0,0,1,1.827-.575,1.706,1.706,0,0,1,.279.59c.042.1,0,.243.171.277.026.006.039.128.039.2a2.5,2.5,0,0,1-.339,1.324,2.152,2.152,0,0,0-.2,1.276,7.281,7.281,0,0,0,.785-.067.3.3,0,0,0,.159-.242c-.016-.193.075-.217.229-.248.213-.043.415-.149.629-.183a1.2,1.2,0,0,1,.406.1.422.422,0,0,0,.037-.2.46.46,0,0,1,.147-.425A19.921,19.921,0,0,1,14.965,1.4a.231.231,0,0,1,.367.051.61.61,0,0,1,.04.059c.433.659.416.7-.165,1.222-.754.672-1.493,1.362-2.229,2.054a.448.448,0,0,0-.094.289c-.008.221.033.446.01.664-.04.379-.2.5-.584.5-.087,0-.174-.009-.278-.014a2.725,2.725,0,0,1-.184.4,4.592,4.592,0,0,1-.534.721.665.665,0,0,1-.9.155,3.157,3.157,0,0,0-.634-.22.482.482,0,0,0-.069.5.586.586,0,0,1,.045.347,1.115,1.115,0,0,0,.091.713.9.9,0,0,0,.376.5A1.5,1.5,0,0,1,10.6,9.7a4.212,4.212,0,0,1,.9,1.244,1.623,1.623,0,0,0,.319.423c.213-.284.079-.81.66-.787a4.549,4.549,0,0,0,.066.529,7.563,7.563,0,0,0,.234.8,2.023,2.023,0,0,1,.114,1.1,3.38,3.38,0,0,0-.008.753c.008.294.015.589.043.881.015.161.086.317.108.478a3.626,3.626,0,0,1,.058.7.575.575,0,0,0,.381.647c.125.05.263.065.387.117a.865.865,0,0,1,.273.172c.1.1.08.225-.056.261a2.473,2.473,0,0,1-.673.11c-.5-.011-1-.059-1.5-.095A1.085,1.085,0,0,1,11.716,17c-.259-.066-.31-.162-.236-.425.019-.068.031-.138.053-.206s.046-.117.079-.2c-.208-.066-.205-.184-.1-.35.2-.3-.047-.571-.077-.856a1.769,1.769,0,0,0-.114-.36,3.79,3.79,0,0,1-.282-1.285,1.266,1.266,0,0,1,0-.238c.028-.145-.02-.213-.148-.3s-.19-.266-.3-.388a1.935,1.935,0,0,0-.412-.383C9.84,11.805,9.481,11.634,9.116,11.443Z" transform="translate(-2.247 -0.252)"/><circle class="a" cx="0.5" cy="0.5" r="0.5" transform="translate(10)"/></svg></span> <!-- -->Cricket Home</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-schedule/" class="jsx-896135805">Schedule</a></li><li class="jsx-896135805 "><a href="/cricketnext/cricket-live-scorecard/" class="jsx-896135805">Live Score</a></li><li class="jsx-896135805 "><a href="/cricketnext/results/" class="jsx-896135805">Results</a></li><li class="jsx-896135805 cn-dropdown"><a class="jsx-896135805">Ranking</a><div id="rankingBtn" class="jsx-896135805 drop-inner"><div class="jsx-896135805 dropdown-sec"><ul class="jsx-896135805 droplist-2 cnTabContent RankingInternational"><li class="jsx-896135805"><a href="/cricketnext/test-ranking.html" class="jsx-896135805">Test</a></li><li class="jsx-896135805"><a href="/cricketnext/odi-ranking.html" class="jsx-896135805">ODI</a></li><li class="jsx-896135805"><a href="/cricketnext/t20-ranking.html" class="jsx-896135805">T20</a></li></ul><ul class="jsx-896135805 droplist-2 cnTabContent RankingDomestic hide"><li class="jsx-896135805"><a href="/cricketnext/test-ranking.html" class="jsx-896135805">Test</a></li><li class="jsx-896135805"><a href="/cricketnext/odi-ranking.html" class="jsx-896135805">ODI</a></li><li class="jsx-896135805"><a href="/cricketnext/t20-ranking.html" class="jsx-896135805">T20</a></li></ul></div></div></li><li class="jsx-896135805"><a href="/cricketnext/latestnews/" class="jsx-896135805">News</a></li><li class="jsx-896135805"><a href="/cricketnext/photogallery/" class="jsx-896135805">Photos</a></li><li class="jsx-896135805"><a href="/cricketnext/videos/" class="jsx-896135805">Videos</a></li><li class="jsx-896135805 cn-dropdown"><a href="" class="jsx-896135805">Teams</a><div id="teamsBtn" class="jsx-896135805 drop-inner"><div class="jsx-896135805 dropdown-sec"><ul class="jsx-896135805 droplist-2 cnTabContent TeamsInternational"><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/australia-squad-1.html" class="jsx-896135805">Australia</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/bangladesh-squad-2.html" class="jsx-896135805">Bangladesh</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/england-squad-3.html" class="jsx-896135805">England</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/india-squad-4.html" class="jsx-896135805">India</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/new-zealand-squad-5.html" class="jsx-896135805">New Zealand</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/pakistan-squad-6.html" class="jsx-896135805">Pakistan</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/south-africa-squad-7.html" class="jsx-896135805">South Africa</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/sri-lanka-squad-8.html" class="jsx-896135805">Sri Lanka</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/west-indies-squad-9.html" class="jsx-896135805">West Indies</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/zimbabwe-squad-10.html" class="jsx-896135805">Zimbabwe</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/bermuda-squad-11.html" class="jsx-896135805">Bermuda</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/canada-squad-12.html" class="jsx-896135805">Canada</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/ireland-squad-13.html" class="jsx-896135805">Ireland</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/kenya-squad-14.html" class="jsx-896135805">Kenya</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/netherlands-squad-15.html" class="jsx-896135805">Netherlands</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/scotland-squad-16.html" class="jsx-896135805">Scotland</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/hong-kong-squad-19.html" class="jsx-896135805">Hong Kong</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/namibia-squad-20.html" class="jsx-896135805">Namibia</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/united-arab emirates-squad-21.html" class="jsx-896135805">United Arab Emirates</a></li><li class="jsx-896135805"><a href="/cricketnext/cricket-teams/usa-squad-22.html" class="jsx-896135805">USA</a></li></ul></div></div></li><li class="jsx-896135805 series-btn"><a href="https://www.news18.com/cricketnext/series/india-vs-new-zealand-2022.html" style="color:#ff0000" class="jsx-896135805">IND vs NZ</a></li><li class="jsx-896135805 series-btn"><a href="https://www.news18.com/cricketnext/news/series/australia-vs-england-2022.html" style="color:#ff0000" class="jsx-896135805">AUS vs ENG</a></li></ul><div class="jsx-435456715"><div class="jsx-435456715 gsearch_box"><div class="jsx-435456715 Close exp_search exp"><div class="jsx-435456715 expinner"><div id="gsearch" class="jsx-435456715"></div></div></div></div><ul class="jsx-435456715 header_search fright clearfix"><li class="jsx-435456715"><a class="jsx-435456715 search_icon spriteimage1"></a></li></ul></div><div style="display:none" class="jsx-896135805 nav-rgt-inside-links"><div style="display:flex;justify-content:flex-end;background:#f5f5f5;height:47px;opacity:0.9" class="jsx-896135805 social-links"></div><div style="border-top:1px solid #ccc" class="jsx-896135805 sub-nav"><ul class="jsx-896135805 h-links clearfix"><li class="jsx-896135805"><a href="/" class="jsx-896135805">Home</a></li><li class="jsx-896135805"><a href="/movies/" class="jsx-896135805">Movies</a></li><li class="jsx-896135805"><a href="/cricketnext/" class="jsx-896135805">Cricket</a></li><li class="jsx-896135805"><a href="/india/" class="jsx-896135805">India</a></li><li class="jsx-896135805"><a href="/entertainment/" class="jsx-896135805">Showsha</a></li><li class="jsx-896135805"><a href="/politics/" class="jsx-896135805">Politics</a></li><li class="jsx-896135805"><a href="/world/" class="jsx-896135805">World</a></li><li class="jsx-896135805"><a href="/education-career/" class="jsx-896135805">Education</a></li><li class="jsx-896135805"><a href="/business/" class="jsx-896135805">Business</a></li><li class="jsx-896135805"><a href="/buzz/" class="jsx-896135805">Buzz</a></li><li class="jsx-896135805"><a href="/opinion/" class="jsx-896135805">Opinion</a></li><li class="jsx-896135805"><a href="/photogallery/" class="jsx-896135805">Photos</a></li><li class="jsx-896135805"><a href="/videos/" class="jsx-896135805">Videos</a></li><li class="jsx-896135805"><a href="/explainers/" class="jsx-896135805">Explainers</a></li><li class="jsx-896135805"><a href="/web-stories/" class="jsx-896135805">Web Stories</a></li><li class="jsx-896135805"><a href="/tech/" class="jsx-896135805">Tech</a></li><li class="jsx-896135805"><a href="/auto/" class="jsx-896135805">Auto</a></li><li class="jsx-896135805"><a href="/lifestyle/" class="jsx-896135805">Lifestyle</a></li><li class="jsx-896135805"><a href="/lifestyle/health-and-fitness/" class="jsx-896135805">Health</a></li><li class="jsx-896135805"><a href="/lifestyle/travel/" class="jsx-896135805">Travel</a></li><li class="jsx-896135805"><a href="/lifestyle/food/" class="jsx-896135805">Food</a></li><li class="jsx-896135805"><a href="/sports/" class="jsx-896135805">Sports</a></li><li class="jsx-896135805"><a href="/business/markets/" class="jsx-896135805">Markets</a></li><li class="jsx-896135805"><a href="/business/tax/" class="jsx-896135805">Tax</a></li><li class="jsx-896135805"><a href="/business/cryptocurrency/" class="jsx-896135805">Cryptocurrency</a></li><li class="jsx-896135805"><a href="/business/savings-and-investments/" class="jsx-896135805">Savings and Investments</a></li><li class="jsx-896135805"><a href="/breaking-news/" class="jsx-896135805">Breaking News</a></li><li class="jsx-896135805"><a href="/aqi-india/" class="jsx-896135805">AQI</a></li><li class="jsx-896135805"><a href="/political-gossip-whispers/" class="jsx-896135805">Power Circuit</a></li><li class="jsx-896135805"><a href="/elections/" class="jsx-896135805">Elections</a></li><li class="jsx-896135805"><a href="/entertainment/movie-reviews/" class="jsx-896135805">Movie Reviews</a></li><li class="jsx-896135805"><a href="/mobiles/" class="jsx-896135805">Mobile Phones</a></li><li class="jsx-896135805"><a href="/cities/" class="jsx-896135805">City News</a></li></ul><div class="jsx-896135805 b-link"><a href="/news/" class="jsx-896135805">Latest</a><a href="/assembly-elections-2022/" class="jsx-896135805">Elections</a><a href="/football/fifa-world-cup-2022/" class="jsx-896135805"><strong style="color:#e1261c">FIFA World Cup</strong></a><a href="/bigg-boss/" class="jsx-896135805"><strong style="color:#e1261c">Bigg Boss</strong></a><a href="/pro-kabaddi/" class="jsx-896135805">PKL</a><a href="/explainers/" class="jsx-896135805">Explainers</a><a href="/lifestyle/" class="jsx-896135805">Lifestyle</a><a href="/web-stories/" class="jsx-896135805">Web Stories</a><a href="/sports/" class="jsx-896135805">Sports</a><a href="/tech/" class="jsx-896135805">Tech</a><a href="/auto/" class="jsx-896135805">Auto</a><a href="/sustainable-is-attainable-news18-and-tata-power-initiative/" class="jsx-896135805">#SustainableIsAttainable</a><a href="https://news18propertyexpo.com/" class="jsx-896135805">Virtual Real Estate Fair</a></div></div></div></div></nav><div style="height:128px;overflow-y:auto" class="jsx-896135805"></div><div style="padding:6px 0;height:96px;display:flex;justify-content:center;margin-bottom:6px;margin-top:6px" class="jsx-896135805 topAdd"><div style="height:90px;display:flex;justify-content:center;align-items:center" class="jsx-896135805"><div id="CRINXT_ENG_DESKTOP/CRINXT_ENG_NEWS/CRINXT_ENG_NEWS_AS/CRINXT_ENG_NWS_AS_ROS_ATF_728" data-custom="new add implementation" class="jsx-896135805"><div style="position:relative;margin:0 auto;overflow:hidden;display:table;flex-direction:column;align-items:center;padding-bottom:0px;width:100%" class="jsx-10193515 ad-div"><div class="myad  adunitContainer"><div class="adBox" id="ATF_728_id"></div></div></div></div><div style="height:0;width:0;overflow:hidden" class="jsx-896135805"></div></div></div><script type="application/ld+json" class="jsx-896135805">{"@context":"https://schema.org","@type":"NewsArticle","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.news18.com/cricketnext/news/the-buck-stops-with-the-coach-and-the-captain-only-selectors-cant-be-blamed-k-shriniwas-rao-6482887.html"},"isPartOf":{"@type":"CreativeWork","name":"News18","url":"https://www.news18.com"},"inLanguage":"en","headline":"'The Buck Stops With The Coach and The Captain, Only Selectors Can't Be Blamed': K Shriniwas Rao","description":"Ayaz Memon said that he doesn't agree with only the selection panel being sacked","keywords":"K Shriniwas Rao, Ayaz Memon, Rohit Sharma, Rahul Dravid, Indian Selectors, Chetan Sharma, BCCI","articleSection":"Cricketnext","url":"https://www.news18.com/cricketnext/news/the-buck-stops-with-the-coach-and-the-captain-only-selectors-cant-be-blamed-k-shriniwas-rao-6482887.html","image":["https://images.news18.com/ibnlive/uploads/2022/07/rohit-sharma-rahul-dravid-bcci-165917377516x9.jpg","https://images.news18.com/ibnlive/uploads/2022/07/rohit-sharma-rahul-dravid-bcci-16591737754x3.jpg","https://images.news18.com/ibnlive/uploads/2022/07/rohit-sharma-rahul-dravid-bcci.jpg"],"datePublished":"2022-11-19T12:00:13+05:30","dateModified":"2022-11-27T18:24:34+05:30","articleBody":"The Board of Control for Cricket in India (BCCI) has sacked the Chetan Sharma-led selection committee after India’s debacle in the T20 World Cup 2022. The cricket board has also invited applications for the position of National Selectors on Friday.\nChetan (North zone), Harvinder Singh (Central Zone), Sunil Joshi (South Zone) and Debasish Mohanty (East Zone) have had the shortest stint as senior national selectors in recent times. Some of them were appointed in 2020 and some in 2021.\nSenior cricket journalist Ayaz Memon and Network 18, Group Editor Sports, K Shriniwas Rao, in an discussion with Senior Associate Editor, CNN News18, said shared their thoughts on the selection panel getting sacked.\nK Shriniwas Rao said he is not at all surprised by the selection panel getting sacked.\n&amp;#8220;I am not surprised at all by the selection panel being asked to go. There are multiple ways to look at it, like some may call it like you know a typical knee-jerk reaction. At some point in time somebody will have to accept that this is not the team or this is not the set of combinations that needed to have gone to Australia so to each his own here but at the at the end of the the day they have to start somewhere,&amp;#8221; Shriniwas said.\n&amp;#8220;There is a great deal of correction required now. Who&amp;#8217;s here to put a finger and say where exactly does this correction process needs to begin from so the BCCI decided to begin by changing the settings of the selection committee,&amp;#8221; the Group Editors added.\nAlso Read: After Soaring High in T20Is, SKY Primed for ODI Spotlight\nAyaz on the other hand said that he doesn&amp;#8217;t agree with only the selection panel being sacked.\n&amp;#8220;I completely don&amp;#8217;t agree with only the selection committee being said to remove because we live in an age where the selectors writ doesn&amp;#8217;t learn run large. Can\nyou imagine that Captain accepting just the players given by the the selection committee. Once the selection is made it is the captain and the chief coach who decide which team is going to play in the playing XI,&amp;#8221; Ayaz said.\nEven Shriniwas Rao echoed the same emotions.\nHe said, &amp;#8220;You think KL Rahul would be in the team if the coach and Captain didn&amp;#8217;t want him? I mean surely as I was pointing out this decision is not purely the selector&amp;#8217;s decision and the sense I got from the likes of Vikram Rathore and Rahul Dravid in the press conferences is that they believed in KL Rahul and they wanted him there. It&amp;#8217;s not really something that has been imposed by the selectors, it&amp;#8217;s something that the captain and the coach would have wanted. The buck stops with the coach and the captain.&amp;#8221;\n\nGet the latest Cricket News, Schedule  and  Cricket Live Scores  here","author":[{"@type":"Person","name":"Cricketnext Staff","url":"https://www.news18.com/byline/cricketnext-staff.html"}],"contentLocation":[{"@type":"AdministrativeArea","name":"Mumbai, India"}],"publisher":{"@type":"NewsMediaOrganization","name":"News18","url":"https://www.news18.com","logo":{"@type":"ImageObject","url":"https://images.news18.com/static_news18/pix/ibnhome/news18/images/news18-logo-v1.png","width":600,"height":60}},"associatedMedia":{"@type":"imageObject","url":"https://images.news18.com/ibnlive/uploads/2022/07/rohit-sharma-rahul-dravid-bcci-165917377516x9.jpg","caption":"Team India captain Rohit Sharma and head coach Rahul Dravid (BCCI Image)","description":"Team India captain Rohit Sharma and head coach Rahul Dravid (BCCI Image)","height":900,"width":1600}}</script><script type="application/ld+json" class="jsx-896135805">{"@context":"https://schema.org","@type":"BreadcrumbList","itemListElement":[{"@type":"ListItem","position":1,"item":{"@id":"https://www.news18.com/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@id":"https://www.news18.com/cricketnext/","name":"Cricket Home"}},{"@type":"ListItem","position":3,"item":{"@id":"https://www.news18.com/cricketnext/latestnews/","name":"News"}},{"@type":"ListItem","position":4,"item":{"name":"'The Buck Stops With The Coach and The Captain, Only Selectors Can't Be Blamed': K Shriniwas Rao"}}]}</script><script type="application/ld+json" class="jsx-896135805">{"@context":"https://schema.org/","@type":"WebPage","name":"'The Buck Stops With The Coach and The Captain, Only Selectors Can't Be Blamed': K Shriniwas Rao","description":"The Board of Control for Cricket in India (BCCI) has sacked the Chetan Sharma-led selection committee after India’s debacle in the T20 World Cup 2022. The cricket board has also invited applications for the position of National Selectors on Friday.","keywords":"K Shriniwas Rao, Ayaz Memon, Rohit Sharma, Rahul Dravid, Indian Selectors, Chetan Sharma, BCCI","speakable":{"@type":"SpeakableSpecification","cssSelector":"['The Buck Stops With The Coach and The Captain, Only Selectors Can't Be Blamed': K Shriniwas Rao ,Ayaz Memon said that he doesn't agree with only the selection panel being sacked]"},"url":"https://www.news18.com/cricketnext/news/the-buck-stops-with-the-coach-and-the-captain-only-selectors-cant-be-blamed-k-shriniwas-rao-6482887.html"}</script><script type="application/ld+json" class="jsx-896135805">{"@context":"https://schema.org","@type":"SiteNavigationElement","name":["Home","Movies","Cricket","India","Showsha","Politics","World","Education","Business","Buzz","Opinion","Photos","Videos","Explainers","Web Stories","Tech","Auto","Lifestyle","Health","Travel","Food","Sports","Markets","Tax","Cryptocurrency","Savings and Investments","Breaking News","AQI","Power Circuit","Elections","Movie Reviews","Mobile Phones","City News"],"url":["https://www.news18.com/","https://www.news18.com/movies/","https://www.news18.com/cricketnext/","https://www.news18.com/india/","https://www.news18.com/entertainment/","https://www.news18.com/politics/","https://www.news18.com/world/","https://www.news18.com/education-career/","https://www.news18.com/business/","https://www.news18.com/buzz/","https://www.news18.com/opinion/","https://www.news18.com/photogallery/","https://www.news18.com/videos/","https://www.news18.com/explainers/","https://www.news18.com/web-stories/","https://www.news18.com/tech/","https://www.news18.com/auto/","https://www.news18.com/lifestyle/","https://www.news18.com/lifestyle/health-and-fitness/","https://www.news18.com/lifestyle/travel/","https://www.news18.com/lifestyle/food/","https://www.news18.com/sports/","https://www.news18.com/business/markets/","https://www.news18.com/business/tax/","https://www.news18.com/business/cryptocurrency/","https://www.news18.com/business/savings-and-investments/","https://www.news18.com/breaking-news/","https://www.news18.com/aqi-india/","https://www.news18.com/political-gossip-whispers/","https://www.news18.com/elections/","https://www.news18.com/entertainment/movie-reviews/","https://www.news18.com/mobiles/","https://www.news18.com/cities/"]}</script><section class="scrollable-element" style="background:#f5f5f5;clear:both;overflow-anchor:none"><div class="body_container" style="max-width:1244px;box-sizing:initial;width:100%;margin:0 auto;padding:15px 20px;background:#fff"><div class="story-container " id="6482887" data-srno="1" data-article-id="6482887" data-url="https://www.news18.com/cricketnext/news/the-buck-stops-with-the-coach-and-the-captain-only-selectors-cant-be-blamed-k-shriniwas-rao-6482887.html" data-title="&#x27;The Buck Stops With The Coach and The Captain, Only Selectors Can&#x27;t Be Blamed&#x27;: K Shriniwas Rao" data-section="Cricketnext" style="margin-bottom:50px"><div data-ga7="News18 | Digital | Cricketnext Staff | NA" data-ga8="FMS | Manual | News18 | Cricketnext | Article" data-ga9="[{&quot;author_name&quot;:&quot;Kanav Bali&quot;},{&quot;source&quot;:&quot;News18&quot;},{&quot;article_id&quot;:6482887},{&quot;dateMDY&quot;:&quot;11/19/2022&quot;},{&quot;publishTime&quot;:&quot;12:00&quot;}]" data-author="Cricketnext Staff" data-ga14="Cricketnext" data-ga15="article" data-ga16="No Tags" style="display:flex;justify-content:space-between" class="jsx-771931618 story-container-child"><div class="jsx-1609252102 articleshare-new"><div class="jsx-1609252102 articleshare-new-in"><a href="https://web.whatsapp.com/send?text=&#x27;The%20Buck%20Stops%20With%20The%20Coach%20and%20The%20Captain,%20Only%20Selectors%20Can&#x27;t%20Be%20Blamed&#x27;:%20K%20Shriniwas%20Rao-https://www.news18.com/cricketnext/news/the-buck-stops-with-the-coach-and-the-captain-only-selectors-cant-be-blamed-k-shriniwas-rao-6482887.html" target="_blank" rel="nofollow" class="jsx-1609252102"><svg enable-background="new 0 0 100 100" height="100px" id="Layer_1" version="1.1" viewBox="0 0 100 100" width="100px" xml:space="preserve" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink" class="jsx-1609252102"><g class="jsx-1609252102"><defs class="jsx-1609252102"><rect height="100" id="SVGID_1_" width="100" class="jsx-1609252102"></rect></defs><path d="M95,49.247c0,24.213-19.779,43.841-44.182,43.841c-7.747,0-15.025-1.98-21.357-5.455L5,95.406   l7.975-23.522c-4.023-6.606-6.34-14.354-6.34-22.637c0-24.213,19.781-43.841,44.184-43.841C75.223,5.406,95,25.034,95,49.247    M50.818,12.388c-20.484,0-37.146,16.535-37.146,36.859c0,8.066,2.629,15.535,7.076,21.611l-4.641,13.688l14.275-4.537   c5.865,3.851,12.891,6.097,20.437,6.097c20.481,0,37.146-16.533,37.146-36.858C87.964,28.924,71.301,12.388,50.818,12.388    M73.129,59.344c-0.273-0.447-0.994-0.717-2.076-1.254c-1.084-0.537-6.41-3.138-7.4-3.494c-0.993-0.359-1.717-0.539-2.438,0.536   c-0.721,1.076-2.797,3.495-3.43,4.212c-0.632,0.719-1.263,0.809-2.347,0.271c-1.082-0.537-4.571-1.673-8.708-5.334   c-3.219-2.847-5.393-6.364-6.025-7.44c-0.631-1.075-0.066-1.656,0.475-2.191c0.488-0.482,1.084-1.255,1.625-1.882   c0.543-0.628,0.723-1.075,1.082-1.793c0.363-0.717,0.182-1.344-0.09-1.883c-0.27-0.537-2.438-5.825-3.34-7.976   c-0.902-2.151-1.803-1.793-2.436-1.793c-0.631,0-1.354-0.09-2.076-0.09s-1.896,0.269-2.889,1.344   c-0.992,1.076-3.789,3.676-3.789,8.963c0,5.288,3.879,10.397,4.422,11.114c0.541,0.716,7.49,11.92,18.5,16.223   C63.2,71.177,63.2,69.742,65.186,69.562c1.984-0.179,6.406-2.599,7.312-5.107C73.398,61.943,73.398,59.792,73.129,59.344" class="jsx-1609252102"></path></g></svg></a><a href="https://www.facebook.com/sharer.php?u=https://www.news18.com/cricketnext/news/the-buck-stops-with-the-coach-and-the-captain-only-selectors-cant-be-blamed-k-shriniwas-rao-6482887.html&amp;t=&#x27;The%20Buck%20Stops%20With%20The%20Coach%20and%20The%20Captain,%20Only%20Selectors%20Can&#x27;t%20Be%20Blamed&#x27;:%20K%20Shriniwas%20Rao" target="_blank" rel="nofollow" class="jsx-1609252102"><svg enable-background="new 0 0 512 512" height="512px" id="Layer_1" version="1.1" viewBox="0 0 512 512" width="512px" xml:space="preserve" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink" class="jsx-1609252102"><g class="jsx-1609252102"><path d="M191.844,511.5V288.375h-68.313V188h69.875v-83.063c0,0,3.188-104.625,92.813-105.438h99.75V98h-61.875   c0,0-26.125,0-26.125,29.438c0,29.375,0,62.313,0,62.313h89.5l-10.75,100.313h-77.188V511.5H191.844z" class="jsx-1609252102"></path></g></svg></a><a href="https://twitter.com/share?text=&#x27;The%20Buck%20Stops%20With%20The%20Coach%20and%20The%20Captain,%20Only%20Selectors%20Can&#x27;t%20Be%20Blamed&#x27;:%20K%20Shriniwas%20Rao&amp;url=https://www.news18.com/cricketnext/news/the-buck-stops-with-the-coach-and-the-captain-only-selectors-cant-be-blamed-k-shriniwas-rao-6482887.html" target="_blank" rel="nofollow" class="jsx-1609252102"><svg enable-background="new 0 0 56.693 56.693" height="56.693px" id="Layer_1" version="1.1" viewBox="0 0 56.693 56.693" width="56.693px" xml:space="preserve" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink" class="jsx-1609252102"><path d="M52.837,15.065c-1.811,0.805-3.76,1.348-5.805,1.591c2.088-1.25,3.689-3.23,4.444-5.592c-1.953,1.159-4.115,2-6.418,2.454  c-1.843-1.964-4.47-3.192-7.377-3.192c-5.581,0-10.106,4.525-10.106,10.107c0,0.791,0.089,1.562,0.262,2.303  c-8.4-0.422-15.848-4.445-20.833-10.56c-0.87,1.492-1.368,3.228-1.368,5.082c0,3.506,1.784,6.6,4.496,8.412  c-1.656-0.053-3.215-0.508-4.578-1.265c-0.001,0.042-0.001,0.085-0.001,0.128c0,4.896,3.484,8.98,8.108,9.91  c-0.848,0.23-1.741,0.354-2.663,0.354c-0.652,0-1.285-0.063-1.902-0.182c1.287,4.015,5.019,6.938,9.441,7.019  c-3.459,2.711-7.816,4.327-12.552,4.327c-0.815,0-1.62-0.048-2.411-0.142c4.474,2.869,9.786,4.541,15.493,4.541  c18.591,0,28.756-15.4,28.756-28.756c0-0.438-0.009-0.875-0.028-1.309C49.769,18.873,51.483,17.092,52.837,15.065z" class="jsx-1609252102"></path></svg></a><a href="https://getpocket.com/edit?url=https://www.news18.com/cricketnext/news/the-buck-stops-with-the-coach-and-the-captain-only-selectors-cant-be-blamed-k-shriniwas-rao-6482887.html" target="_blank" rel="nofollow" class="jsx-1609252102"><svg enable-background="new 0 0 128 128" id="Social_Icons" version="1.1" viewBox="0 0 128 128" xml:space="preserve" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink" class="jsx-1609252102"><g id="_x37__stroke" class="jsx-1609252102"><g id="Pocket" class="jsx-1609252102"><rect clip-rule="evenodd" fill="none" fill-rule="evenodd" height="128" width="128" class="jsx-1609252102"></rect><path clip-rule="evenodd" d="M64.089,65.128    c-0.324-0.301-0.57-0.523-0.809-0.752c-7.747-7.442-15.485-14.893-23.243-22.323c-3.554-3.403-9.008-3.278-12.394,0.24    c-3.335,3.465-3.289,8.953,0.218,12.342c10.053,9.712,20.135,19.395,30.234,29.06c3.365,3.22,8.546,3.187,11.959,0.008    c1.367-1.273,2.7-2.582,4.047-3.877c8.635-8.299,17.265-16.604,25.909-24.893c2.077-1.992,3.165-4.398,2.892-7.263    c-0.347-3.643-2.268-6.265-5.717-7.521c-3.438-1.252-6.565-0.496-9.218,2.038c-4.342,4.147-8.664,8.317-12.994,12.478    C71.37,58.128,67.765,61.594,64.089,65.128z M64.067,6.688c17.398,0,34.796-0.005,52.194,0.003    c5.391,0.003,10.025,3.481,11.368,8.535c0.212,0.798,0.345,1.643,0.346,2.467c0.008,13.594,0.075,27.189-0.048,40.782    c-0.125,13.888-4.326,26.462-12.875,37.441c-9.513,12.219-21.782,20.266-36.903,23.761c-34.72,8.023-67.887-14.386-76.074-45.75    c-1.091-4.181-1.835-8.424-1.871-12.742C0.084,46.724-0.006,32.263,0,17.803C0.003,11.716,5.433,6.696,11.773,6.691    C29.204,6.68,46.636,6.688,64.067,6.688z" fill="#F43B53" fill-rule="evenodd" id="Pocket_1_" class="jsx-1609252102"></path></g></g></svg></a><a href="mailto:?subject=&#x27;The%20Buck%20Stops%20With%20The%20Coach%20and%20The%20Captain,%20Only%20Selectors%20Can&#x27;t%20Be%20Blamed&#x27;:%20K%20Shriniwas%20Rao&amp;body=https://www.news18.com/cricketnext/news/the-buck-stops-with-the-coach-and-the-captain-only-selectors-cant-be-blamed-k-shriniwas-rao-6482887.html" target="_blank" rel="nofollow" class="jsx-1609252102"><svg height="16px" version="1.1" viewBox="0 0 20 16" width="20px" xmlns="https://www.w3.org/2000/svg" xmlnssketch="https://www.bohemiancoding.com/sketch/ns" xmlns:xlink="https://www.w3.org/1999/xlink" class="jsx-1609252102"><title class="jsx-1609252102"></title><desc class="jsx-1609252102"></desc><defs class="jsx-1609252102"></defs><g fill="none" fill-rule="evenodd" id="Page-1" stroke="none" stroke-width="1" class="jsx-1609252102"><g fill="#000000" id="Icons-Communication" transform="translate(-168.000000, -43.000000)" class="jsx-1609252102"><g id="email" transform="translate(168.000000, 43.000000)" class="jsx-1609252102"><path d="M18,0 L2,0 C0.9,0 0,0.9 0,2 L0,14 C0,15.1 0.9,16 2,16 L18,16 C19.1,16 20,15.1 20,14 L20,2 C20,0.9 19.1,0 18,0 L18,0 Z M18,4 L10,9 L2,4 L2,2 L10,7 L18,2 L18,4 L18,4 Z" id="Shape" class="jsx-1609252102"></path></g></g></g></svg></a><a href="https://telegram.me/share/url?url=https://www.news18.com/cricketnext/news/the-buck-stops-with-the-coach-and-the-captain-only-selectors-cant-be-blamed-k-shriniwas-rao-6482887.html" target="_blank" rel="nofollow" class="jsx-1609252102 tely"><svg enable-background="new 0 0 24 24" height="512" viewBox="0 0 24 24" width="512" xmlns="http://www.w3.org/2000/svg" class="jsx-1609252102"><path fill="#fff" d="m9.417 15.181-.397 5.584c.568 0 .814-.244 1.109-.537l2.663-2.545 5.518 4.041c1.012.564 1.725.267 1.998-.931l3.622-16.972.001-.001c.321-1.496-.541-2.081-1.527-1.714l-21.29 8.151c-1.453.564-1.431 1.374-.247 1.741l5.443 1.693 12.643-7.911c.595-.394 1.136-.176.691.218z" class="jsx-1609252102"></path></svg></a></div></div><div id="left" style="width:914px" class="jsx-771931618 sectionLeft"><div style="border-bottom:1px dotted #939393;padding-bottom:5px;text-transform:uppercase;display:flex;justify-content:space-between" class="jsx-771931618 bredcrum"><div style="font-weight:400;font-size:11px;min-height:24px;align-items:center;line-height:15px" class="jsx-771931618 bredcrum-txt"><a href="/"><span>Home</span></a> » 
                                        <a href="/cricketnext/"> <span>Cricket Home</span></a> » <a  href="/cricketnext/latestnews/"> <span >News</span></a> » <span class="act">'The Buck Stops With The Coach and The Captain, Only Selectors Can't Be Blamed': K Shriniwas Rao</span></div><div style="font-size:11px;color:#939393;position:relative;flex-shrink:0;margin-left:25px;height:24px;display:flex;align-items:center" class="jsx-771931618 read_story"><span style="border-radius:50%;width:12px;height:12px;margin-right:4px;position:absolute;top:4px;left:-19px;border:1px solid #939393" class="jsx-771931618"></span>2-MIN READ</div></div><div style="padding:10px 0;margin-bottom:50px;position:relative" class="jsx-771931618 article-box story_body"><h1 style="font-size:36px;line-height:44px;color:#282828;font-weight:600;min-height:48px;margin-bottom:6px" class="jsx-771931618 article_heading"> <!-- -->&#x27;The Buck Stops With The Coach and The Captain, Only Selectors Can&#x27;t Be Blamed&#x27;: K Shriniwas Rao</h1><div class="jsx-771931618 article_details_list"><div class="jsx-771931618 article_headline"><p class="jsx-771931618">By:  <span class="jsx-771931618 article_postby"><a href="https://www.news18.com/byline/cricketnext-staff.html"><span>Cricketnext Staff</span></a></span></p></div><div class="jsx-771931618 article_headline"><p class="jsx-771931618">Last Updated: <span style="color:#808080;text-transform:uppercase" class="jsx-771931618">November 27, 2022, 18:24 IST</span></p></div><div class="jsx-771931618 article_headline"><p class="jsx-771931618"><span id="location_info">Mumbai, India</span></p></div></div><div style="display:flex;justify-content:space-between;background:#f3f3f3;padding:0 15px 10px 10px;border-bottom:5px solid #e1261c" class="jsx-771931618 article_byno_limg"><div style="width:510px;padding-top:10px;position:relative" class="jsx-771931618 article_bimg"><figure style="line-height:0;width:510px" class="jsx-771931618"><div><div style="max-height:360px" class="jsx-771931618"><div style="width:100%;height:285px;margin:0 auto" class="jsx-771931618"><iframe frameborder="0" class="lazyload" allowfullscreen="" src="" data-src="https://www.youtube.com/embed/VPh3NQqnzqQ" width="510px" height="285px" class="jsx-771931618"></iframe></div></div></div></figure></div><div style="width:359px;padding-top:10px" class="jsx-771931618 article_bnow_box"><h2 style="min-height:24px;font-size:14px;line-height:24px;color:#3f3f3f;font-weight:400" class="jsx-771931618">Ayaz Memon said that he doesn&#x27;t agree with only the selection panel being sacked</h2><ul class="jsx-771931618 article_bnow"><li class="jsx-771931618"><span class="jsx-1429733795 bnowSpan">Follow us:</span><div class="jsx-1429733795 insidefollwicon"><a href="https://www.facebook.com/cnnnews18/" target="_blank" rel="nofollow" class="jsx-1429733795"><svg enable-background="new 0 0 512 512" height="512px" id="Layer_1" version="1.1" viewBox="0 0 512 512" width="512px" xml:space="preserve" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink" class="jsx-1429733795"><g class="jsx-1429733795"><path d="M191.844,511.5V288.375h-68.313V188h69.875v-83.063c0,0,3.188-104.625,92.813-105.438h99.75V98h-61.875   c0,0-26.125,0-26.125,29.438c0,29.375,0,62.313,0,62.313h89.5l-10.75,100.313h-77.188V511.5H191.844z" class="jsx-1429733795"></path></g></svg>Facebook</a><a href="https://twitter.com/CNNnews18" target="_blank" rel="nofollow" class="jsx-1429733795"><svg enable-background="new 0 0 56.693 56.693" height="56.693px" id="Layer_1" version="1.1" viewBox="0 0 56.693 56.693" width="56.693px" xml:space="preserve" xmlns="https://www.w3.org/2000/svg" xmlns:xlink="https://www.w3.org/1999/xlink" class="jsx-1429733795"><path d="M52.837,15.065c-1.811,0.805-3.76,1.348-5.805,1.591c2.088-1.25,3.689-3.23,4.444-5.592c-1.953,1.159-4.115,2-6.418,2.454  c-1.843-1.964-4.47-3.192-7.377-3.192c-5.581,0-10.106,4.525-10.106,10.107c0,0.791,0.089,1.562,0.262,2.303  c-8.4-0.422-15.848-4.445-20.833-10.56c-0.87,1.492-1.368,3.228-1.368,5.082c0,3.506,1.784,6.6,4.496,8.412  c-1.656-0.053-3.215-0.508-4.578-1.265c-0.001,0.042-0.001,0.085-0.001,0.128c0,4.896,3.484,8.98,8.108,9.91  c-0.848,0.23-1.741,0.354-2.663,0.354c-0.652,0-1.285-0.063-1.902-0.182c1.287,4.015,5.019,6.938,9.441,7.019  c-3.459,2.711-7.816,4.327-12.552,4.327c-0.815,0-1.62-0.048-2.411-0.142c4.474,2.869,9.786,4.541,15.493,4.541  c18.591,0,28.756-15.4,28.756-28.756c0-0.438-0.009-0.875-0.028-1.309C49.769,18.873,51.483,17.092,52.837,15.065z" class="jsx-1429733795"></path></svg>Twitter</a><a href="https://www.instagram.com/cnnnews18/" target="_blank" rel="nofollow" class="jsx-1429733795"><svg data-name="Layer 21" height="24" id="Layer_21" viewBox="0 0 24 24" width="24" xmlns="https://www.w3.org/2000/svg" class="jsx-1429733795"><title class="jsx-1429733795"></title><path d="M15.5,3h-7A5.5,5.5,0,0,0,3,8.5v7A5.5,5.5,0,0,0,8.5,21h7A5.5,5.5,0,0,0,21,15.5v-7A5.5,5.5,0,0,0,15.5,3Zm4,12.5a4.00454,4.00454,0,0,1-4,4h-7a4.00454,4.00454,0,0,1-4-4v-7a4.0045,4.0045,0,0,1,4-4h7a4.0045,4.0045,0,0,1,4,4Z" class="jsx-1429733795"></path><path d="M12,7.5A4.5,4.5,0,1,0,16.5,12,4.5,4.5,0,0,0,12,7.5ZM12,15a3,3,0,1,1,3-3A3.0034,3.0034,0,0,1,12,15Z" class="jsx-1429733795"></path><circle cx="16.70001" cy="7.29999" r="1" class="jsx-1429733795"></circle></svg>Instagram</a><a href="https://t.me/news18dotcom/" target="_blank" rel="nofollow" class="jsx-1429733795"><svg id="Layer_1" data-name="Layer 1" xmlns="https://www.w3.org/2000/svg" viewBox="0 0 510 427.71" class="jsx-1429733795"><g id="comp_335-telegram" class="jsx-1429733795"><path d="M509.55,81.08l-77,363c-5.8,25.61-20.94,32-42.46,19.92L272.85,377.55,216.27,432c-6.26,6.26-11.5,11.5-23.57,11.5L201.13,324,418.47,127.65c9.45-8.43-2.05-13.1-14.69-4.67L135.1,292.16,19.42,256c-25.16-7.86-25.61-25.17,5.24-37.23L477.1,44.42C498.05,36.57,516.38,49.09,509.55,81.08Z" transform="translate(-1 -42.15)" class="jsx-1429733795"></path></g></svg>Telegram</a><a href="https://news.google.com/publications/CAAqBwgKMOaqjQsw-KufAw?hl=en-IN&amp;gl=IN&amp;ceid=IN%3Aen" target="_blank" rel="nofollow" class="jsx-1429733795"><svg id="Layer_1" data-name="Layer 1" xmlns="http://www.w3.org/2000/svg" viewBox="0 0 500 489.56" class="jsx-1429733795"><defs class="jsx-1429733795"><style>.cls-1{fill:#4d4d4d;}.cls-2{fill:#fff;}</style></defs><path d="M255.62,500.77q-91.06,0-182.12,0C52.33,500.76,43,491.5,43,470.48q0-113.84,0-227.66c0-21.23,9.21-30.6,30.23-30.61q183.45,0,366.88,0c20.59,0,30.07,9.49,30.08,29.88q0,114.27,0,228.53c0,20.6-9.39,30.13-29.78,30.14Q348,500.82,255.62,500.77ZM213.7,375.48a43.17,43.17,0,0,1-65.57,15.76,43.8,43.8,0,0,1-9.39-59.56c13.66-19.79,39.41-24.8,60.41-11.76,12.08,7.49,22.77,6.17,29.07-3.61s2.91-20.63-8.69-28.1c-17.1-11-35.7-15-56-12.42-42.46,5.5-73.17,44.08-69.91,88.26,3.06,41.4,40.12,74.66,82.38,73.91,43.39-.77,79.19-35.43,80.42-77.87.42-14.56-6.94-22.37-21.56-22.47-18.69-.12-37.37-.07-56.05,0-14.12,0-22.45,7.08-22.48,18.81s8.18,18.89,22.33,19C190,375.57,201.36,375.48,213.7,375.48ZM357.62,337.6c-14.27,0-28.55-.16-42.81,0-12.05.17-20,7.56-20.35,18.28-.31,11.14,7.6,19.31,20.07,19.45q42.38.45,84.76,0c12.57-.12,20.48-8,20.34-19.19s-8.29-18.42-20.94-18.56C385,337.47,371.31,337.59,357.62,337.6Zm-13.2-25c9.92,0,19.84.16,29.76,0,12-.24,20.17-7.72,20.53-18.34.36-10.45-7.77-19.09-19.5-19.34q-30.63-.61-61.27,0c-12,.23-19.68,8.34-19.48,19.18s8.18,18.25,20.19,18.51C324.57,312.78,334.49,312.61,344.42,312.61Zm.13,125.59v0h28c.58,0,1.16,0,1.75-.05,12.45-.8,20.75-8.71,20.4-19.42-.36-10.89-8.78-18.21-21.42-18.28q-28.87-.15-57.77,0c-12.71.07-20.9,7.35-21.1,18.42s7.62,18.76,20.36,19.22C324.7,438.48,334.63,438.2,344.55,438.2Z" transform="translate(-6 -11.22)" class="jsx-1429733795 cls-1"></path><path d="M12.53,207.32C10,191.06,7.12,177.37,6.07,163.55c-.94-12.37,7.71-22,20.72-24.28,36.73-6.58,73.53-12.82,110.32-19.15q84-14.48,168.11-28.92c17.28-3,29.2,4.62,32.51,22,3.82,20,7,40.15,10.62,61.24h-11.2c-86.71,0-173.42.36-260.13-.23C50.42,174,29.07,182.14,12.53,207.32Z" transform="translate(-6 -11.22)" class="jsx-1429733795 cls-1"></path><path d="M419.71,68c-20.3-2.22-39.67-4-58.92-6.58a241.6,241.6,0,0,1-31.45-6.56C311.59,50,294.6,55,277.47,57.93,218.28,68,159.14,78.21,100,88.34a57,57,0,0,1-5.93.35c0-19.56-.85-39,.34-58.29.65-10.5,11.33-18.13,22.19-19,2.9-.23,5.83-.18,8.75-.18q131.28,0,262.57,0c23.16,0,31.79,8.56,31.81,31.45Z" transform="translate(-6 -11.22)" class="jsx-1429733795 cls-1"></path><path d="M499.22,204.16c-2.81-3.25-4.43-5.11-6-7-12.68-14.75-28.7-22.56-48.19-22.73-19.2-.17-38.4,0-58.28,0-4.21-24.44-8.34-48.38-12.64-73.34,17.5,1.88,34.2,3.62,50.88,5.49,18.53,2.08,37,4.34,55.55,6.41,18.19,2,27.07,12.6,25.26,30.72C503.8,163.28,501.54,182.84,499.22,204.16Z" transform="translate(-6 -11.22)" class="jsx-1429733795 cls-1"></path><path d="M213.7,375.48c-12.34,0-23.67.09-35,0-14.15-.15-22.36-7.23-22.33-19s8.36-18.77,22.48-18.81c18.68-.06,37.36-.11,56.05,0,14.62.1,22,7.91,21.56,22.47-1.23,42.44-37,77.1-80.42,77.87-42.26.75-79.32-32.51-82.38-73.91-3.26-44.18,27.45-82.76,69.91-88.26,20.26-2.63,38.86,1.4,56,12.42,11.6,7.47,14.91,18.45,8.69,28.1s-17,11.1-29.07,3.61c-21-13-46.75-8-60.41,11.76a43.8,43.8,0,0,0,9.39,59.56A43.17,43.17,0,0,0,213.7,375.48Z" transform="translate(-6 -11.22)" class="jsx-1429733795 cls-2"></path><path d="M357.62,337.59c13.69,0,27.38-.12,41.07,0,12.65.14,20.79,7.5,20.94,18.56s-7.77,19.07-20.34,19.19q-42.37.4-84.76,0c-12.47-.14-20.38-8.31-20.07-19.45.31-10.72,8.3-18.11,20.35-18.28C329.07,337.44,343.35,337.6,357.62,337.59Z" transform="translate(-6 -11.22)" class="jsx-1429733795 cls-2"></path><path d="M344.42,312.61c-9.93,0-19.85.17-29.77,0-12-.26-20-7.74-20.19-18.51s7.48-18.95,19.48-19.18q30.63-.58,61.27,0c11.73.25,19.86,8.89,19.5,19.34-.36,10.62-8.55,18.1-20.53,18.34C364.26,312.77,354.34,312.61,344.42,312.61Z" transform="translate(-6 -11.22)" class="jsx-1429733795 cls-2"></path><path d="M344.55,438.2c-9.92,0-19.85.28-29.76-.07-12.74-.46-20.56-8.1-20.36-19.22s8.39-18.35,21.1-18.42q28.89-.18,57.77,0c12.64.07,21.06,7.39,21.42,18.28.35,10.71-8,18.62-20.4,19.42-.59,0-1.17.05-1.75.05h-28Z" transform="translate(-6 -11.22)" class="jsx-1429733795 cls-2"></path></svg>Google News</a></div></li></ul></div></div><article style="font-family:&#x27;PT Serif&#x27;,serif;font-size:18px;line-height:26px" class="jsx-771931618 article-content-box first_big_character"><div class="jsx-771931618"><p id="0" class="story_para_0"></p><p id="0" class="story_para_0">The Board of Control for <a href="https://www.news18.com/cricketnext/">Cricket</a> in <a href="https://www.news18.com/india/">India</a> (BCCI) has sacked the Chetan Sharma-led selection committee after India’s debacle in the T20 <a href="https://www.news18.com/world/">World</a> Cup 2022. The cricket board has also invited applications for the position of National Selectors on Friday.</p><p id="1" class="story_para_1"></p><p id="1" class="story_para_1">Chetan (North zone), Harvinder Singh (Central Zone), Sunil Joshi (South Zone) and Debasish Mohanty (East Zone) have had the shortest stint as senior national selectors in recent times. Some of them were appointed in 2020 and some in 2021.</p><p id="2" class="story_para_2">Senior cricket journalist Ayaz Memon and Network 18, Group Editor Sports, K Shriniwas Rao, in an discussion with Senior Associate Editor, CNN News18, said shared their thoughts on the selection panel getting sacked.\</p><p id="3" class="story_para_3">K Shriniwas Rao said he is not at all surprised by the selection panel getting sacked.</p><p id="4" class="story_para_4">“I am not surprised at all by the selection panel being asked to go. There are multiple ways to look at it, like some may call it like you know a typical knee-jerk reaction. At some point in time somebody will have to accept that this is not the team or this is not the set of combinations that needed to have gone to Australia so to each his own here but at the at the end of the the day they have to start somewhere,&quot; Shriniwas said.</p><nonfly class="article_mad" adUnit="CRINXT_ENG_DESKTOP/CRINXT_ENG_NEWS/CRINXT_ENG_NEWS_AS/CRINXT_ENG_NWS_AS_ROS_MID_728" slotId="nw18-dynamic-div-6482887_4_14" id="new_ad_5"></nonfly><p id="5" class="story_para_5">“There is a great deal of correction required now. Who’s here to put a finger and say where exactly does this correction process needs to begin from so the BCCI decided to begin by changing the settings of the selection committee,&quot; the Group Editors added.</p><p id="6" class="story_para_6"></p><p class="story_para_1"><strong>Also Read:</strong> <a href="https://www.news18.com/cricketnext/news/after-soaring-high-in-t20is-suryakumar-yadav-primed-for-odi-spotlight-6410173.html">After Soaring High in T20Is, SKY Primed for ODI Spotlight</a></p><p id="7" class="story_para_7"></p><p class="story_para_1">Ayaz on the other hand said that he doesn’t agree with only the selection panel being sacked.</p><p id="8" class="story_para_8"></p><p class="story_para_1">“I completely don’t agree with only the selection committee being said to remove because we live in an age where the selectors writ doesn’t learn run large. Can</p><p id="9" class="story_para_9">you imagine that Captain accepting just the players given by the the selection committee. Once the selection is made it is the captain and the chief coach who decide which team is going to play in the playing XI,&quot; Ayaz said.</p><p id="10" class="story_para_10"></p><p class="story_para_1">Even Shriniwas Rao echoed the same emotions.</p><p id="11" class="story_para_11"></p><p class="story_para_1">He said, “You think KL Rahul would be in the team if the coach and Captain didn’t want him? I mean surely as I was pointing out this decision is not purely the selector’s decision and the sense I got from the likes of Vikram Rathore and Rahul Dravid in the press conferences is that they believed in KL Rahul and they wanted him there. It’s not really something that has been imposed by the selectors, it’s something that the captain and the coach would have wanted. The buck stops with the coach and the captain.&quot;</p><div id="taboola-mid-article-thumbnails"></div><p id="12" class="story_para_12"></p><p class="story_para_1"></p><p id="13" class="story_para_13">Get the latest <a href="https://www.news18.com/cricketnext/latestnews/">Cricket News</a>,<a href="https://www.news18.com/cricketnext/cricket-schedule/"> Schedule </a> and <a href="https://www.news18.com/cricketnext/cricket-live-scorecard/"> Cricket Live Scores </a> here</p><script>setTimeout(() => {
                            let playerscriptCounter = 0;

                            window.addEventListener('scroll', () => {
                                let pageYOffset = window.pageYOffset;
                            
                                if(pageYOffset > 80 && playerscriptCounter == 0) {
                                    let playerscript = document.createElement('script'); 
                                    playerscript.src =  "//images.news18.com/static_news18/pix/ibnhome/news18/js/custom-js/pubstack-player/news18-gujrati/prod-player-react.js"; 
                                    playerscript.defer =  true;
                                    document.body.appendChild(playerscript);
                            
                                    playerscriptCounter++
                                }
                            });

                            let playerscript2 = document.createElement('script'); 
                              playerscript2.src =  "https://images.news18.com/static_news18/pix/ibnhome/news18/js/custom-js/pubstack-player/news18-english/v2/production-player.js?v=1.3"; 
                              playerscript2.defer =  true;
                              document.body.appendChild(playerscript2);

                        }, 15000)</script>
                        <script type="text/javascript">
                            window._taboola = window._taboola || [];
                            _taboola.push({
                                mode: 'thumbnails-mid-article',
                                container: 'taboola-mid-article-thumbnails',
                                placement: 'Mid Article Thumbnails',
                                target_type: 'mix'
                            });
                        </script></div></article><div style="color:#e1261c" class="jsx-771931618 queryvideo"></div><div class="jsx-771931618 authorBox21 article_author"><div class="jsx-771931618 author_box"><div class="author_box_inner"><div class="text1 author_content"><div class="about_social"><p class="about_author">About the Author</p><ul class="social-icon"><li><a class="email" href="mailto:Cricketnext.Staff@nw18.com"></a></li><li><a class="web" href="https://www.news18.com/cricketnext/"></a></li></ul></div><a class="smalldesc1 author_name" href="/byline/cricketnext-staff.html"><span>Cricketnext Staff</span></a><p>A team of reporters, writers and editors brings you news, analyses, features, live scores, results, stats and everything that’s cricket from all over <!-- -->...<a href="/byline/cricketnext-staff.html" class="read_more">Read More</a></p></div></div></div></div><div class="tags_outter"><div class="published_date"><span>first published:</span>November 19, 2022, 12:00 IST</div><div class="updated_date"><span>last updated:</span>November 27, 2022, 18:24 IST</div></div><div style="min-height:527px" class="jsx-771931618"><div id="taboola-below-article-thumbnails" class="jsx-771931618"></div><script class="jsx-771931618">
                                window._taboola = window._taboola || []; 
                                _taboola.push({
                                    mode: 'thumbnails-a',
                                    container: 'taboola-below-article-thumbnails',
                                    placement: 'Below Article Thumbnails',
                                    target_type: 'mix'
                                });</script></div><button id="twitter-share-btn" class="jsx-771931618"><svg enable-background="new 0 0 56.693 56.693" height="30px" id="Layer_1" version="1.1" viewBox="0 0 56.693 56.693" width="30px" xmlns="https://www.w3.org/2000/svg" class="jsx-771931618"><path d="M52.837,15.065c-1.811,0.805-3.76,1.348-5.805,1.591c2.088-1.25,3.689-3.23,4.444-5.592c-1.953,1.159-4.115,2-6.418,2.454  c-1.843-1.964-4.47-3.192-7.377-3.192c-5.581,0-10.106,4.525-10.106,10.107c0,0.791,0.089,1.562,0.262,2.303  c-8.4-0.422-15.848-4.445-20.833-10.56c-0.87,1.492-1.368,3.228-1.368,5.082c0,3.506,1.784,6.6,4.496,8.412  c-1.656-0.053-3.215-0.508-4.578-1.265c-0.001,0.042-0.001,0.085-0.001,0.128c0,4.896,3.484,8.98,8.108,9.91  c-0.848,0.23-1.741,0.354-2.663,0.354c-0.652,0-1.285-0.063-1.902-0.182c1.287,4.015,5.019,6.938,9.441,7.019  c-3.459,2.711-7.816,4.327-12.552,4.327c-0.815,0-1.62-0.048-2.411-0.142c4.474,2.869,9.786,4.541,15.493,4.541  c18.591,0,28.756-15.4,28.756-28.756c0-0.438-0.009-0.875-0.028-1.309C49.769,18.873,51.483,17.092,52.837,15.065z" class="jsx-771931618"></path></svg></button></div></div><div id="right" class="jsx-806591267 sectionRight"><div style="width:300px;min-height:250px;background:#cecece" class="jsx-806591267"><div style="position:relative;margin:0 auto;overflow:hidden;display:table;flex-direction:column;align-items:center;padding-bottom:20px;min-width:300px;min-height:250px" class="jsx-10193515 ad-div"><div class="myad  adunitContainer"><div class="adBox" id="ATF_300_id_6482887"></div></div></div><div style="display:none" class="jsx-806591267 PG1x1"><div style="position:relative;margin:0 auto;overflow:hidden;display:table;flex-direction:column;align-items:center;padding-bottom:20px;min-width:1px;min-height:1px" class="jsx-10193515 ad-div"><div class="myad  adunitContainer"><div class="adBox" id="PG_1x1_6482887"></div></div></div><div style="position:relative;margin:0 auto;overflow:hidden;display:table;flex-direction:column;align-items:center;padding-bottom:20px;min-width:1px;min-height:1px" class="jsx-10193515 ad-div"><div class="myad  adunitContainer"><div class="adBox" id="Shosh_OOP_id_6482887"></div></div></div><div style="position:relative;margin:0 auto;overflow:hidden;display:table;flex-direction:column;align-items:center;padding-bottom:20px;min-width:1px;min-height:1px" class="jsx-10193515 ad-div"><div class="myad  adunitContainer"><div class="adBox" id="Skin_OOP_id_6482887"></div></div></div></div></div><div style="margin-top:20px" class="jsx-806591267"></div><div style="margin-top:20px" class="jsx-806591267"></div><div style="margin-top:20px" class="jsx-806591267"></div><div style="width:300px;min-height:250px;background:#cecece" class="jsx-806591267"><div style="position:relative;margin:0 auto;overflow:hidden;display:table;flex-direction:column;align-items:center;padding-bottom:20px;min-width:300px;min-height:250px" class="jsx-10193515 ad-div"><div class="myad  adunitContainer"><div class="adBox" id="BTF_300_id_undefined"></div></div></div></div><div style="margin-top:20px" class="jsx-806591267"></div></div></div></div></div></section><script data-cfasync="false" type="text/javascript"></script></div><script id="__NEXT_DATA__" type="application/json">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</script></body></html>